GFI Software Aurea SMB Solutions


Home » GFI User Forums » Kerio Connect » Connect 9.2.10 and Java
Connect 9.2.10 and Java [message #146415] Wed, 14 August 2019 22:42 Go to next message
anarvey is currently offline  anarvey
Messages: 46
Registered: May 2007
Is there any guidance on what to do about Java. I assume that the instance of Java that got installed with Kerio may have updated itself to a version that isn't licensed for free anymore.

Is there some way to go to OpenJDK without screwing anything up?
Re: Connect 9.2.10 and Java [message #146426 is a reply to message #146415] Fri, 16 August 2019 21:53 Go to previous messageGo to next message
bruggles is currently offline  bruggles
Messages: 133
Registered: April 2008
Am I curious as well. Thanks in Advance.
Re: Connect 9.2.10 and Java [message #146427 is a reply to message #146426] Fri, 16 August 2019 23:51 Go to previous messageGo to next message
Bud Durland is currently offline  Bud Durland
Messages: 517
Registered: December 2013
Location: Plattsburgh, NY
Just curious -- where does Kerio Connect use Java?
Re: Connect 9.2.10 and Java [message #146437 is a reply to message #146427] Mon, 19 August 2019 16:57 Go to previous messageGo to next message
bruggles is currently offline  bruggles
Messages: 133
Registered: April 2008
Can anyone from Support answer this? Thanks.
Re: Connect 9.2.10 and Java [message #146438 is a reply to message #146437] Mon, 19 August 2019 21:48 Go to previous messageGo to next message
jcooper is currently offline  jcooper
Messages: 89
Registered: May 2009
Location: Syracuse, NY
If you get some sort of response via other channels, would you mind posting the upshot here? I was planning on upgrading this weekend but I'm hesitant without seeing a resolution to whatever the JAVA problem is. What specifically happened when you upgraded? Does KC simply not work now?

We're hosting on a Mac with an external RAID.

Thanks,

Jeff
Re: Connect 9.2.10 and Java [message #146450 is a reply to message #146438] Wed, 21 August 2019 20:05 Go to previous messageGo to next message
wag357 is currently offline  wag357
Messages: 53
Registered: August 2004
Jeff,

They are referring to the fact that Java now requires a license to be run in a business.
Before, Java was free and now, if you run the JRE in a business, you have to pay a license fee.
We need to know if Java is still required in connect 9.2.10 and if so, is the license fee paid through our renewals of Kerio.
Re: Connect 9.2.10 and Java [message #146455 is a reply to message #146450] Fri, 23 August 2019 11:30 Go to previous messageGo to next message
ian.bugeja is currently offline  ian.bugeja
Messages: 395
Registered: March 2017
Location: Malta
Hi all

Kerio Connect still uses Java Runtime JRE and this is used for the Chat functionality.

There are NO additional license costs required for running Kerio Connect with respect to Java since the release is prior to the license changes came into effect. Going forward we will also be moving to OpenJDK which is released under Open Source and latest versions can also be used in production commercial environments.



Ian Bugeja
GFI Software
Re: Connect 9.2.10 and Java [message #146507 is a reply to message #146455] Thu, 29 August 2019 15:06 Go to previous messageGo to next message
anarvey is currently offline  anarvey
Messages: 46
Registered: May 2007
That's a good response but the Java that gets installed with Kerio -even if was prior to the release of the version that requires licensing - is constantly asking to be updated and if you update to the latest version aren't you automatically subsumed under the new regime an need to require a license?

I am sure many Kerio users have already innocently updated their Java to a version that requires licensing.

To stay free you have to have always said "NO" to the constant Java prompts to upgrade.
Re: Connect 9.2.10 and Java [message #146522 is a reply to message #146507] Tue, 03 September 2019 09:32 Go to previous messageGo to next message
JohnyJohny1 is currently offline  JohnyJohny1
Messages: 1
Registered: September 2019
Thanks a lot in advance!
Re: Connect 9.2.10 and Java [message #146532 is a reply to message #146507] Wed, 04 September 2019 08:27 Go to previous message
martin.kaufmann is currently offline  martin.kaufmann
Messages: 62
Registered: August 2018
Location: Germany

anarvey wrote on Thu, 29 August 2019 15:06

To stay free you have to have always said "NO" to the constant Java prompts to upgrade.
Which is a security nightmare. Just saying... Confused


Kerio Connect 9.2.10
CentOS 7.8
Previous Topic: Where were the dev team?
Next Topic: Increasing the received message size limit on Kerio Connect
Goto Forum:
  


Current Time: Fri Jan 24 18:53:31 CET 2020

Total time taken to generate the page: 0.04730 seconds