GFI Software Aurea SMB Solutions


Home » GFI User Forums » Kerio Connect » Text index and search not working
Text index and search not working [message #138173] Mon, 15 January 2018 16:46 Go to next message
beachmat is currently offline  beachmat
Messages: 73
Registered: November 2010
Since last week when I installed a recent security update for Mac OS 10.11.6 on the Mac running Connect server, text search in webmail and Connect client is not working. I checked on the server and the full text index reports an error, size 0, see logs. The log says

[12/Jan/2018 18:19:29] externalLogger.cpp: FullText [external]: SEVERE (SocketClient.receivingLoop): org.xml.sax.SAXParseException; lineNumber: 1; columnNumber: 1; Premature end of file./com.sun.org.apache.xerces.internal.util.ErrorHandlerWr apper.createSAXParseException(ErrorHandlerWrapper:203)/com.s un.org.apache.xerces.internal.util.ErrorHandlerWrapper.fatal Error(ErrorHandlerWrapper:177)/com.sun.org.apache.xerces.int ernal.impl.XMLErrorReporter.reportError(XMLErrorReporter:400 )/com.sun.org.apache.xerces.internal.impl.XMLErrorReporter.r eportError(XMLErrorReporter:327)/com.sun.org.apache.xerces.i nternal.impl.XMLScanner.reportFatalError(XMLScanner:1472)/co m.sun.org.apache.xerces.internal.impl.XMLDocumentScannerImpl $PrologDriver.next(XMLDocumentScannerImpl:1014)/com.sun.org. apache.xerces.internal.impl.XMLDocumentScannerImpl.next(XMLD ocumentScannerImpl:602)/com.sun.org.apache.xerces.internal.i mpl.XMLDocumentFragmentScannerImpl.scanDocument(XMLDocumentF ragmentScannerImpl:505)/com.sun.org.apache.xerces.internal.p a
[12/Jan/2018 18:19:31] FullTextServiceImpl.cpp: Failed to initiate comunication (1) to FullTextServer.
[12/Jan/2018 18:19:31] StoreHeritageConfigurator.hpp: Failed to start fulltext service.

Anyone have any idea how to fix this?

Thanks
Re: Text index and search not working [message #138174 is a reply to message #138173] Mon, 15 January 2018 16:56 Go to previous messageGo to next message
Kerio/GFI Brian is currently offline  Kerio/GFI Brian
Messages: 852
Registered: March 2004
Location: California
It sounds like the full text index is corrupt and you may need to rebuild the index (Advanced options -> Store Directory).

Brian Carmichael
Instructional Content Architect
Re: Text index and search not working [message #138175 is a reply to message #138174] Mon, 15 January 2018 17:02 Go to previous messageGo to next message
beachmat is currently offline  beachmat
Messages: 73
Registered: November 2010
Yes I tried that and it says failed to launch rebuilding full text search index.
Re: Text index and search not working [message #138176 is a reply to message #138175] Mon, 15 January 2018 17:20 Go to previous messageGo to next message
Kerio/GFI Brian is currently offline  Kerio/GFI Brian
Messages: 852
Registered: March 2004
Location: California
Disable the full text feature (make sure to click apply). Then remove the contents of the fulltext folder. Then re-enable the feature. It should re-index at that point.

Brian Carmichael
Instructional Content Architect
Re: Text index and search not working [message #138177 is a reply to message #138176] Mon, 15 January 2018 17:38 Go to previous messageGo to next message
beachmat is currently offline  beachmat
Messages: 73
Registered: November 2010
That seems to have sorted it, thanks.
Re: Text index and search not working [message #146065 is a reply to message #138176] Tue, 25 June 2019 15:24 Go to previous messageGo to next message
RustyB is currently offline  RustyB
Messages: 53
Registered: April 2010
Quote:
Disable the full text feature (make sure to click apply). Then remove the contents of the fulltext folder. Then re-enable the feature. It should re-index at that point.
My index status was stuck on rebuilding, so I did as you recommended. Disable full text search, click apply, remove contents of fulltext folder, and then re-enable full text. I did this last Friday. It has been almost four days now and it still says Rebuilding (102 users remaining). Is this normal time. I only have 136 mailboxes (only 101 are active). The Dashboard tells me my total storage size is 1.3 TB.
Re: Text index and search not working [message #146075 is a reply to message #146065] Tue, 25 June 2019 21:58 Go to previous messageGo to next message
dhardyuk is currently offline  dhardyuk
Messages: 18
Registered: May 2019
Quote:

The Dashboard tells me my total storage size is 1.3 TB
Thats enormous, if that's all mail data being indexed it won't be quick to finish.

From https://www.gfi.com/products-and-solutions/email-and-messagi ng-solutions/kerio-connect/specifications/system-requirement s

Quote:
HARDWARE
PC
Minimal HW configuration (1-20 users):
CPU 1 GHz 64-bit, 2 GB RAM, 40 GB of free space for message store and backup
Recommended HW configuration (20-100 users):
CPU 2 GHz 64-bit, 4 GB RAM, 160 GB of free space for message store and backup
Recommended HW configuration (100+ users):
CPU 2.8 GHz 64-bit Quad Core, 16 GB RAM, 64-bit OS, 200 GB+ of free space for message store and backup
Does your server meet these specs?
Re: Text index and search not working [message #146076 is a reply to message #146075] Tue, 25 June 2019 23:48 Go to previous messageGo to next message
RustyB is currently offline  RustyB
Messages: 53
Registered: April 2010
I run on VMWare. I currently have 8 GB or RAM allocated. I could always give it more, but typical usage is usually around 3-4 GB. Processor is 2.4 GHz. I have two processor cores allocated to the machine, and CPU usage is normally around 5%. OS is 64 bit and plenty of free space.

I've been keeping an eye on it. Before I deleted the fulltext folder, the index size was about 15GB. It currently is at about 8.5 GB and appears to be slowly growing. But still says 102 users remaining since this morning.
Re: Text index and search not working [message #146082 is a reply to message #146076] Wed, 26 June 2019 11:28 Go to previous messageGo to next message
dhardyuk is currently offline  dhardyuk
Messages: 18
Registered: May 2019
I know that this doesn't change the reality of the situation;

Email was never intended to be more than the electronic equivalent of a postcard or an envelope. The fact that systems have been able to keep pace with the demands of users has not helped manage expectations because the go to has always been to add more grunt or disk.

Email is not the answer if the users want/need to retain a massive quantity (count) or volume (size) of messages. How do those same users document and control SMS messages? SMS has moved into the space that email occupied 20 years ago, messages are to a large extent disposable and not globally archived by organisations .... WhatsApp, Twitter and so on

The relentless growth and sprawl of platforms is creating a massive governance liability for proper legal discovery. Never mind business continuity or timely disaster recovery, it is terrifying.

Edited to add:
In approximate terms you are running at about 10GB per user, the Kerio Connect sizing suggests to me that it scales at 200GB/100 users = 2GB per user. What does Perfmon say about the disk queues for your storage? Where and what is your storage - is it a performance SAN (with auto tiering for performance) running flash and fast disk or is it nearer to an NFS share on a noisy lan? Neither answer is right or wrong, both scenarios 'work' but the differences in cost/stability/performance help when managing user expectations.

[Updated on: Wed, 26 June 2019 11:53]

Report message to a moderator

Re: Text index and search not working [message #146084 is a reply to message #146082] Wed, 26 June 2019 12:10 Go to previous messageGo to next message
dhardyuk is currently offline  dhardyuk
Messages: 18
Registered: May 2019
Can you tell that this is really playing on my mind.

You really need a properly architected solution that involves something like this:
https://www.gfi.com/products-and-solutions/network-security- solutions/gfi-archiver

Re: Text index and search not working [message #146088 is a reply to message #146084] Wed, 26 June 2019 16:06 Go to previous messageGo to next message
RustyB is currently offline  RustyB
Messages: 53
Registered: April 2010
We do have a Dell Compellent iSCSI SAN with non-SSD drives. I understand what you are saying about users hanging on to old emails, but try telling that to the bosses.

I use the program MailStore on an individual user basis when mailboxes get to big. I have about 40 users over 2 GB, with my worst offender around 30 GB.

Another reason my storage is so large in that I do have indexing turned on for the archive, which currently holds email all the way back to 2014. I've never had a problem before with indexing the archive before, and it is super convenient to be able to search for old messages this way when someone just has to have that old email.

I checked my current Index size and it is at 8554 MB (yesterday was at 8506 MB) and still on 102 users remaining. I knew the process of rebuilding the index would be slow, but we are going on 5 days now and I am not even sure it is half way done. Just seems incredibly slow.

Also, I failed to mention in my original post that I am running the latest version of Kerio (9.2.9 P1) on Debian Linux 8.
Re: Text index and search not working [message #146165 is a reply to message #146088] Mon, 01 July 2019 17:04 Go to previous messageGo to next message
RustyB is currently offline  RustyB
Messages: 53
Registered: April 2010
Here I am 10 days later still waiting for the rebuilding to finish. My index size has grown to 17 GB, which I guess tells me it is still doing something. But the status still says Rebuilding (102 users remaining). I have been on 102 users for quite some time now. I can only assume this is the archive that is taking so long to build the index. I don't see an option in the debug log that I could turn on to see exactly where it is in the process. My word of advice to anyone who will try the above process of turning off full text search, clearing out full text folder, and then enabling full text search again, you might want to turn off indexing of the archive first. Allow the index of all your users to be rebuilt first. And then when this is finished, turn back on the indexing of the archive.
Re: Text index and search not working [message #146180 is a reply to message #146165] Wed, 03 July 2019 21:10 Go to previous messageGo to next message
dhardyuk is currently offline  dhardyuk
Messages: 18
Registered: May 2019
Dude,

Have you got a GFI support ticket raised?

If this were my server I'd leave it running and separately stand up a clean current Debian instance, restore a backup of your Kerio folders (without index) and then run an upgrade to current Kerio Connect over the top. Any indexing issues that carry through will most likely be issues in the underlying mail data. If there are no issues, you have a way forward to take to the business and if there are issues you have something tangible to work with your vendor support.

I have a new (to me) scale out comparison that I have used recently to focus management on the 'scaling appropriately' issue.:

The 1941 Dunkirk evacuation moved 336,000 troops in 72 hours and involved about 850 small boats - i.e. consumer grade hardware, crews unfamiliar with the tools and astonishingly good fortune with the weather
The 1944 Normandy beach landings moved 156,000 troops in 24 hours and comprised 6,939 vessels - professional hardware, people trained for the job and scheduled around specific tides, moon phase and weather

Necessity is the mother of invention, planning is the key to success.

I sincerely hope you get this fixed.
Re: Text index and search not working [message #146193 is a reply to message #146180] Fri, 05 July 2019 15:54 Go to previous messageGo to next message
RustyB is currently offline  RustyB
Messages: 53
Registered: April 2010
The process finally did complete after nearly two weeks. All seems to be working fine now.
Re: Text index and search not working [message #146197 is a reply to message #146193] Sat, 06 July 2019 15:57 Go to previous message
dhardyuk is currently offline  dhardyuk
Messages: 18
Registered: May 2019
Good Smile
Previous Topic: Missing emails after outage
Next Topic: Unable to create Calendar via CalDav in Kerio
Goto Forum:
  


Current Time: Sun Aug 25 05:08:31 CEST 2019

Total time taken to generate the page: 0.02562 seconds