GFI Software

Welcome to the GFI Software community forum! For support please open a ticket from

Home » GFI User Forums » Kerio Connect » Disaster Recovery Failing Using KMSRecover
Disaster Recovery Failing Using KMSRecover [message #151324] Tue, 22 March 2022 15:00 Go to previous message
fishtech is currently offline  fishtech
Messages: 609
Registered: September 2010

I am simulating recovery in case of disaster scenarios, but having some problems accessing the backups using kmsrecover command.

My backup directory for Kerio Connect is an external Pegasus RAID volume. Connect schedules a Full backup every Friday night and Differentials every other night.

The Backup volume is subsequently cloned to SATA disks which are taken off-site.

For testing I have set up a bare-metal MacMini (M1 running 10.15) with a fresh Kerio Connect trial installed. I have connected one of the SATA backup clones. Kerio Connect is not running. Kerio connect has NO settings configured.

I am having problems trying to run KMSRecover commands on the SATA backup clone. For example, when trying to recover a single user's mail folder I run:

sudo /usr/local/kerio/mailserver/kmsrecover -d -u username /Users/admin/Desktop/Recover /Volumes/Mail\ Offsite\ Backup\ 1B/BACKUP/

I get:

No full or copy backup has been found!
Error occurred during recovery process (code 7).

In fact all commands using fmsrecover get the same error.

Can anybody advise why I am getting the error? Perhaps I need to move config files into place before I can run kmsrecover successfully?

Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Previous Topic: no caldav/cardav profile on ipad
Next Topic: DIRECT Cloud backups
Goto Forum:

Current Time: Tue Jun 06 04:47:18 CEST 2023

Total time taken to generate the page: 0.02112 seconds