GFI Software

Welcome to the GFI Software community forum! For support please open a ticket from https://support.gfi.com.

Home » GFI User Forums » GFI MailEssentials » Exchange 2019 issue (Spam mail location)
Exchange 2019 issue [message #151080] Thu, 10 February 2022 17:29 Go to next message
TSBowman is currently offline  TSBowman
Messages: 4
Registered: November 2019
We are an IT company and support several locations that have on-premise Exchange. All are Exchange 2016. Our office uses Exchange 2016 and about 4 months ago installed our first Exchange 2019 server in our office as a ginny-pig to test migrating from 2016 to 2019. The Exchange migration went well.

We installed GFI ME on the new Exchange 2019 server and it seemed to go well. But I got a call from one of the users yesterday complaining about not receiving an email. I checked and the logs show it was received and put into his Junk folder. I checked his Outlook and could not find the email. So I started looking at the server. I was going to check the "Failed Mail" folder on the server. When I clicked on the "C" drive to open it and to browse to the GFI folder, I found 4000 emails in the root of the "C" drive. Dating back to the day the server was brought online. All the emails were designated as spam by GFI.

I continued to watch the folder and the GFI console log and every email that GFI determines is spam is delivered to the root of the "C" drive. Not placed in the Junk folder of the user. Since both the Exchange 2016 and 2019 server are online with an MX records, both still receive emails from the internet. The old 2016 server delivers spam email to the users Junk folder. The new 2019 does not.

Any help or suggestions on how to fix this would be greatly appreciated. We still have several locations to migrate to Exchange 2019 and don't want this issue when we do the migration.

Thanks in advance.
Re: Exchange 2019 issue [message #151085 is a reply to message #151080] Fri, 11 February 2022 01:25 Go to previous messageGo to next message
Nick.Geary is currently offline  Nick.Geary
Messages: 60
Registered: January 2021
Hello,

It sounds like the Exchange Pickup/Replay paths are incorrect or missing from the configuration. I would recommend following the steops outlined in the article linked below.

Approved Quarantined emails going to the C drive.

If you are using deliver to Junk, this will increase the SCL value of the email, and then pass it to Exchange. Most likely it is failing to to connect with the Exchange pickup path.


Nick Geary
GFI Software

[Updated on: Fri, 11 February 2022 01:26]

Report message to a moderator

Re: Exchange 2019 issue [message #151090 is a reply to message #151085] Fri, 11 February 2022 17:15 Go to previous message
TSBowman is currently offline  TSBowman
Messages: 4
Registered: November 2019
I ran install wizard clean and now it looks like everything is good.

Thanks for the help.
Previous Topic: Allowlist/Whitelist for External Senders Under Content Filtering
Next Topic: The ability to ignore internal/private/non-routable IP addresses within the IP DNS Blocklist
Goto Forum:
  


Current Time: Mon Sep 26 08:44:27 CEST 2022

Total time taken to generate the page: 0.02381 seconds