GFI Software

Welcome to the GFI Software community forum! For support please open a ticket from https://support.gfi.com.

Home » GFI User Forums » GFI HelpDesk » Cannot use "parent" when current class scope has no parent (Installing Helpdesk)
Cannot use "parent" when current class scope has no parent [message #149629] Mon, 19 April 2021 10:48 Go to next message
JeanYouni is currently offline  JeanYouni
Messages: 3
Registered: April 2021
Hi,

I'm trying to install GFI Helpdesk for the first time and I'm following the installation video on the GFI website.

I reached the point where I copied my key to the support folder and tried to access the setup by opening the website and there I get the below error
"Fatal error: Cannot use "parent" when current class scope has no parent in C:\xampp\htdocs\Support\__swift\library\class.SWIFT.php on line 16"

hope someone has come across this error and can help me.

Regards,
Re: Cannot use "parent" when current class scope has no parent [message #149633 is a reply to message #149629] Mon, 19 April 2021 19:39 Go to previous messageGo to next message
bradley.smith is currently offline  bradley.smith
Messages: 31
Registered: February 2021
It looks like you already created a support ticket with our Support Team concerning this. We appreciate you contacting us.

We will continue to look at this with you on the support ticket.


GFI Customer Support Edge Team
Re: Cannot use "parent" when current class scope has no parent [message #149666 is a reply to message #149629] Wed, 21 April 2021 15:56 Go to previous messageGo to next message
ahurley is currently offline  ahurley
Messages: 1
Registered: April 2021
Hi Jean,

Did you get this resolved as I'm having the same issue on my first instal?

Win Server 2019 and Xampp 8.0.3

Thanks
Anthony
Re: Cannot use "parent" when current class scope has no parent [message #149672 is a reply to message #149666] Fri, 23 April 2021 07:40 Go to previous message
JeanYouni is currently offline  JeanYouni
Messages: 3
Registered: April 2021
Yes,

it seems that Xampp 8.0.3 comes with php 8.0, you need to install and older version of Xampp on another server one that has php version 7.1 then copy the folders php and apache to the 2019 server.

make sure to rename the original php and apache server in the 2019 before the copy.
Previous Topic: Error on Zendesk import
Next Topic: CRON Job Settings
Goto Forum:
  


Current Time: Sun Oct 02 21:44:48 CEST 2022

Total time taken to generate the page: 0.02425 seconds