GFI Software

Welcome to the GFI Software community forum! For support please open a ticket from https://support.gfi.com.

Home » GFI User Forums » Kerio Control » AnyDesk - slow connection (after changing router to kerio ng100 anydesk connects slower)
AnyDesk - slow connection [message #148633] Wed, 02 September 2020 16:18 Go to next message
sajerd is currently offline  sajerd
Messages: 1
Registered: September 2020
Hello everyone!

Im new with Kerio Control, we just changed our router to a kerio ng100.

The configuration is basic (like how it was out of the box after the setup wizard), i only added a few VLAN-s, like we had it before.

Now if i want to connect via AnyDesk to a remote pc, its slower, it takes now (somewhat) 30 sec to establish a connection.

I switched back to the older router, the connection is immediate (1-2 sec from when i click on the remote pc).

I have a w10 1909 x64 and the remote pc-s are mixed, they are w10, w server 2016 and 2019, its all slow.

I tried other software (teamviewer), that was fast, no waiting. I tried RDP on local network, that was fast too.

I tried a few things [disabled the default content filter, application awarenes, etc what i thought could block anydesk from fast connection], but couldnt figure out, what is the problem, so im here.

Thanks in advance for any help/tipps!
Re: AnyDesk - slow connection [message #149302 is a reply to message #148633] Fri, 22 January 2021 10:25 Go to previous messageGo to next message
konabi is currently offline  konabi
Messages: 4
Registered: December 2014
Hi,
I have the same problem.
Dit you found a solution?
Re: AnyDesk - slow connection [message #149380 is a reply to message #148633] Mon, 08 February 2021 18:32 Go to previous messageGo to next message
mwgbr is currently offline  mwgbr
Messages: 61
Registered: June 2012
I can confirm that connections with Anydesk take about 30-60 seconds to be established, when using Kerio Control.
We did not found anything usefull in the logfiles yet.
Re: AnyDesk - slow connection [message #149513 is a reply to message #149380] Mon, 22 March 2021 12:47 Go to previous messageGo to next message
inftest is currently offline  inftest
Messages: 5
Registered: March 2021
Kerio Control:
9.3.5 build 4367
Same problem. When using the Kerio Control gateway, AnyDesk tries to connect for exactly 60 seconds at startup. "Connecting to AnyDesk Network.." Should I expect an official support response to resolve this issue?
Re: AnyDesk - slow connection [message #149514 is a reply to message #149380] Mon, 22 March 2021 12:49 Go to previous messageGo to next message
inftest is currently offline  inftest
Messages: 5
Registered: March 2021
Kerio Control: 9.3.5 build 4367
Same problem. When using the Kerio Control gateway, AnyDesk tries to connect for exactly 60 seconds at startup. "Connecting to AnyDesk Network.." Should I expect an official support response to resolve this issue?
Re: AnyDesk - slow connection [message #149534 is a reply to message #149514] Fri, 26 March 2021 01:12 Go to previous messageGo to next message
Nick.Geary is currently offline  Nick.Geary
Messages: 62
Registered: January 2021
This might be an issue with connecting to Anydesk over port 7070. We have a ticket open with Engineering and it was reported to be related to 'Protocol Inspector.'

One method of testing would be to disable the 'Protocol Inspector' on that port and see what the results are. If that works you might want to try explicitly setting Protocol Inspector= TCP and see if that resolves it.

https://manuals.gfi.com/en/kerio/control/content/security/pr otocol-inspection-in-kerio-control-1689.html

From Anydesk: https://support.anydesk.com/FAQ#

"For standard listening port direct line connection is 7070 (TCP)."

Related to a slow connection over LAN: "AnyDesk might not recognize a direct connection and the session will be established via AnyDesk network. Direct connections display a play symbol in the status bar."

It sounds like the service first tries connecting over port 7070 and if the software has issues, it falls back to another connection method. So based on this I think this would be a good place to start.

If not we can escalate the ticket with engineering.


Nick Geary
GFI Software

[Updated on: Fri, 26 March 2021 01:19]

Report message to a moderator

Re: AnyDesk - slow connection [message #149551 is a reply to message #149534] Wed, 31 March 2021 19:03 Go to previous messageGo to next message
inftest is currently offline  inftest
Messages: 5
Registered: March 2021
Added the AnyDesk tcp 7070 service, disabled the Protocol inspector in it. Does not work. I saw in the services the default rule RAP tcp 7070 Protocol inspector-RAP (Real audio protocol) removed it for the test. Does not work. We need an engineering analysis of AnyDesk traffic from Kerio Control developers.
Re: AnyDesk - slow connection [message #149553 is a reply to message #149551] Wed, 31 March 2021 19:14 Go to previous messageGo to next message
bradley.smith is currently offline  bradley.smith
Messages: 31
Registered: February 2021
If you have not already done so already, please open a support ticket at https://support.keriocontrol.gfi.com/ for this problem.

GFI Customer Support Edge Team
Re: AnyDesk - slow connection [message #149608 is a reply to message #149553] Thu, 15 April 2021 10:58 Go to previous messageGo to next message
OliviaParcker is currently offline  OliviaParcker
Messages: 6
Registered: April 2021
Hi,
I have the same problem.
Dit you found a solution?
Re: AnyDesk - slow connection [message #150129 is a reply to message #148633] Thu, 05 August 2021 19:19 Go to previous messageGo to next message
Ramin is currently offline  Ramin
Messages: 1
Registered: August 2021
any solutions guys?? Please help if someone knows what to do.
Re: AnyDesk - slow connection [message #150135 is a reply to message #150129] Mon, 09 August 2021 04:10 Go to previous messageGo to next message
RangerRU is currently offline  RangerRU
Messages: 1
Registered: August 2021
I have the same problem.

9.3.3 build 3634
icon7.gif  Re: AnyDesk - slow connection [message #150275 is a reply to message #148633] Wed, 22 September 2021 11:14 Go to previous messageGo to next message
Digutec is currently offline  Digutec
Messages: 1
Registered: September 2021
/index.php?t=getfile&id=5258&private=0

Moin zusammen,

ich habe Antwort von GFI bekommen und nach Einbau der Datenverkehrsregel funktioniert Anydesk gewohnt schnell.

Wir haben Rückmeldung vom Hersteller bekommen.

• As stated in the Anydesk-FAQ website, to connect to the AnyDesk, network ports 80, 443, or 6568 are used. For standard listening port direct line connection is 7070 (TCP).https://support.anydesk.com/FAQ
This is most probably not the cause of the issue since you observe the slowness only, and eventually, the connection could be established. To make sure, please verify that there is no Traffic Rule that blocks traffic to "anydesk.com" on TCP ports 80, 443, and 6568. To do that you can refer to the Troubleshooting Traffic Rules in Kerio Control article.
https://support.keriocontrol.gfi.com/hc/en-us/articles/36001 5182000-Troubleshooting-Traffic-Rules-in-Kerio-Control
• On a previous ticket from another customer, I've seen that the issue is resolved by disabling the protocol inspector for all the traffic to "anydesk.com". To do that you can create a traffic rule similar to the below one referring to the Configuring Generic Traffic Rules in Kerio Control article.
https://support.keriocontrol.gfi.com/hc/en-us/articles/36001 5192619-Configuring-Generic-Traffic-Rules-in-Kerio-Control




This way the traffic without the Protocol inspection, will not be checked by the inspector for malicious activity. So, if this resolves the issue, I would kindly suggest you submit a feature request for AnyDesk compatibility. To do that, you can refer to the Submitting a Feature Request on the GFI Feedback Community Portal article.
https://support.gfi.com/hc/en-us/articles/360012841774-Submi tting-a-Feature-Request-on-the-GFI-Feedback-Community-Portal
• Also, I observed a slowness on the initial connection of AnyDesk sessions when I enabled the HTTPS filtering in the test environment.
I could eliminate it by adding "anydesk.com" to the HTTPS exclusions list. To do that you can refer to the Excluding Traffic to/from IP Addresses section of the Filtering HTTPS Connections article.
https://support.keriocontrol.gfi.com/hc/en-us/articles/36001 5191259-Filtering-HTTPS-Connections

[Updated on: Fri, 24 September 2021 10:43] by Moderator

Report message to a moderator

star_16.png  Re: AnyDesk - slow connection [message #152114 is a reply to message #148633] Thu, 30 June 2022 17:46 Go to previous messageGo to next message
inftest is currently offline  inftest
Messages: 5
Registered: March 2021
The problem is SOLVED, AnyDesk is now working fast!
/index.php?t=getfile&id=5349&private=0

In Traffic Rules - add rule
Source: your users for access to anydesk
Destination: ip address group (AnyDeskServers)

All IP addresses of the node relays.net.anydesk.com must be included in the group (AnyDeskServers)
there are 400 addresses in total, you can see them with the nslookup command
nslookup relays.net.anydesk.com

It is also important to disable Protocol Inspector for this rule!

  • Attachment: 1.png
    (Size: 13.54KB, Downloaded 318 times)
icon1.gif  Re: AnyDesk - slow connection [message #152115 is a reply to message #148633] Thu, 30 June 2022 17:49 Go to previous message
inftest is currently offline  inftest
Messages: 5
Registered: March 2021
list of all (relays.net.anydesk.com) node addresses

Previous Topic: Determine website no longer reasonably accessible with update to 9.4.1
Next Topic: Kerio VPN error - udp traffic is probably blocked
Goto Forum:
  


Current Time: Fri Oct 07 14:39:51 CEST 2022

Total time taken to generate the page: 0.02318 seconds