GFI Software Aurea SMB Solutions


Home » GFI User Forums » Kerio Control » error in communication with engine (Unable to configure NIC TCP/IP settings via local console)
error in communication with engine [message #137930] Fri, 15 December 2017 07:25 Go to next message
AlexT82 is currently offline  AlexT82
Messages: 13
Registered: February 2015
Hello,
I've faced with some issues when tried to set up Kerio Control (9.2.4-2223/ 9.2.3-2219) on new Gigabyte barebones - GIGABYTE BRIX IoT GB-EAPD-4200 (Apollo Lake SoC based) with dual Realtek RTL8111HS on board.
1) I cannot configure TCP/IP settings via local console: when trying to apply new settings (static or just switch to DHCP mode), there is an error "error in communication with engine". I can change these settings via Web console but I have to reboot Kerio Control to apply it.
2) If I just unplug network cable and plug it back DHCP configured NIC's status changes to "Connectivity problem" and it takes 4 minutes for NIC to obtain TCP/IP configuration.
I've also noticed a high CPU consumption when I just unplug the network cable and at the moment when NIC finally obtains TCP/IP configuration from DHCP server.

I checked new hardware for compatibility with kernel 3.16. It looks like NIC compatibility is OK (file attached).

Did anybody ever face with similar issues?

PS: I've opened a ticket, but the only suggestion I got from support team is to reinstall Kerio Control! Evil or Very Mad
BTW I tried
  • Attachment: HW_Test.jpg
    (Size: 140.06KB, Downloaded 781 times)

[Updated on: Fri, 15 December 2017 08:02]

Report message to a moderator

Re: error in communication with engine [message #138013 is a reply to message #137930] Tue, 26 December 2017 08:08 Go to previous messageGo to next message
AlexT82 is currently offline  AlexT82
Messages: 13
Registered: February 2015
Update: when I plug the device with Kerio control installed to production network it makes some devices (WiFi access points, some Windows hosts) to fail.
Re: error in communication with engine [message #138607 is a reply to message #137930] Tue, 27 February 2018 07:50 Go to previous messageGo to next message
AlexT82 is currently offline  AlexT82
Messages: 13
Registered: February 2015
The same problem with Fitlet2 (Intel Atom E3930 based) with dual Intel I211 on board.
Compatibility test shows that appropriate network driver is present in the system but it doesn't work properly. Mad
Re: error in communication with engine [message #138676 is a reply to message #137930] Tue, 06 March 2018 07:05 Go to previous messageGo to next message
AlexT82 is currently offline  AlexT82
Messages: 13
Registered: February 2015
Update:
One more issue: Builtin RADIUS fails to authenticate external AP users: MS-CHAP2-Response is incorrect
Re: error in communication with engine [message #138695 is a reply to message #138676] Wed, 07 March 2018 09:53 Go to previous messageGo to next message
renatjon22 is currently offline  renatjon22
Messages: 3
Registered: June 2015
Location: Uzb
The same with Realtek PCIe . error after installing on host machine or on virtual machine (hyper-v 2016). wtf
Re: error in communication with engine [message #138696 is a reply to message #137930] Wed, 07 March 2018 10:32 Go to previous messageGo to next message
AlexT82 is currently offline  AlexT82
Messages: 13
Registered: February 2015
I've found some kind of workaround for Apollo Lake based PCs. Kerio Control release 9.2.2-2172 has no issues when configuring NIC settings and no issues with RADIUS authentication.
All releases prior 9.2.2-2172 do not work at all: Kerio engine cannot be started. All versions released after 9.2.2-2172 have issues described above.
The only problem that still persists: it takes almost 5 minutes for Realtek RTL8111HS NICs to start.

BTW: Kerio Support service just closed my ticket without explanations. Carry on!
icon14.gif  Re: error in communication with engine [message #138697 is a reply to message #138696] Wed, 07 March 2018 10:37 Go to previous message
renatjon22 is currently offline  renatjon22
Messages: 3
Registered: June 2015
Location: Uzb
Thank you . I'll try it.
Previous Topic: Problem with Reverse Proxy and VPN SSTP protocol
Next Topic: port blocked in firewall
Goto Forum:
  


Current Time: Thu Aug 06 01:05:58 CEST 2020

Total time taken to generate the page: 0.03310 seconds