GFI Software

Welcome to the GFI Software community forum! For support please open a ticket from https://support.gfi.com.

Home » GFI User Forums » Kerio Connect » ALL Users' Inboxes "busy" (Result: delayed, Status: 4.3.0 Recipient's mailbox busy, Remote-Host: 127.0.0.1 for all users)
ALL Users' Inboxes "busy" [message #150617] Thu, 09 December 2021 16:39 Go to next message
jcooper is currently offline  jcooper
Messages: 113
Registered: May 2009
Location: Syracuse, NY
Hi,

I've had this come up a couple times in the past few months but never found a concrete underlying cause. Once in a while every account (I have just shy of 100) gets the error

Result: delayed, Status: 4.3.0 Recipient's mailbox busy, Remote-Host: 127.0.0.1

Users cannot log in and all mail gets stuck in queue. Only workaround is a reboot. Upon reboot mail starts flowing again. Both previous times this happened it was at the start of the workday. Though this morning I sent an email successfully before the problem occurred so it's no like something's happening in the middle of the night.

I understand this can happen with too many messages in a particular folder for a particular user, but no idea what would trigger it for everybody.

No RAID or system errors that I can see. Anyone else ever get this and/or have a possible solution?

KC 9.3.1 patch 1 (5492) on Mac OS X (10.14.6), x86_64, Promise RAID (5).

We just did a scheduled reboot of the server four days ago.

Thanks,

Jeff

Re: ALL Users' Inboxes "busy" [message #150618 is a reply to message #150617] Thu, 09 December 2021 16:54 Go to previous messageGo to next message
robinbateman is currently offline  robinbateman
Messages: 224
Registered: April 2012
Location: Oxford(ish) UK

Just a thought... if it is at the start of the day the server is not still backing up is it, as an account that is being backed up will lock it out and a reboot will stop the backup

I have seen it where mail for one user cannot be delivered, then what happens is that the mail for them gets put back into the message queue then returned to processing queue and so it goes around and around until the processing queue is just full of mail for the affected user stopping all the other mail which is backing up in the message queue

When it happens if you look in opened folders does the affected user have a lot of open folders? Is there a clue as to why they have lots of open folders (e.g. $index)


Robin Bateman
One Red Mouse
Blog: http://bit.ly/OWjcGL

[Updated on: Thu, 09 December 2021 16:57]

Report message to a moderator

Re: ALL Users' Inboxes "busy" [message #150620 is a reply to message #150617] Fri, 10 December 2021 12:39 Go to previous messageGo to next message
Matahari-78 is currently offline  Matahari-78
Messages: 6
Registered: September 2018
I had exactly the same problems. On my side it was the internal backup-function. When i tried to backup to a network share it ran forever and finally the server did not respond anymore. It always starts with one user, but affected the whole server in the end. This behavior was reproducible. In the end i decide to use a local backup-folder and transfer the backup-files to the external storage via robocopy.
Re: ALL Users' Inboxes "busy" [message #150622 is a reply to message #150618] Fri, 10 December 2021 14:45 Go to previous message
jcooper is currently offline  jcooper
Messages: 113
Registered: May 2009
Location: Syracuse, NY
I only run backups once a week and it wasn't the other night, but I do zip archives every night to send them off site. Your post got me looking though and I checked the archives. Preceding day's archive (the 8th) wasn't zipped so something stopped it (normally runs about 1am). Nothing in logs from around them except one user had some funky calendar data; doubt that would have done anything. But it does look like something was amiss from the night before. So either archiving hung something up or it didn't run because something happened much earlier than I thought. I briefly turned on backups in the debug log but it looks like it mentioned every message in/out as it gets archived so can easily fill up my drive so I stopped that.

It was happening on all users, which was scary.

I'll keep digging but yes, it is possible it's related to backups/archiving.

Thanks!

Jeff
Previous Topic: win10, outlook 2022 cant install KOFF
Next Topic: password guessing all 5 min
Goto Forum:
  


Current Time: Mon Dec 05 15:14:40 CET 2022

Total time taken to generate the page: 0.02717 seconds