GFI Software Aurea SMB Solutions

Welcome to the GFI Software community forum! For support please open a ticket from https://support.gfi.com.

Home » GFI User Forums » Kerio Connect » Kerio Connect Client not connecting and not asking to do so (Kerio Connect Client is showing a splash screen that never proceeds)
Kerio Connect Client not connecting and not asking to do so [message #149564] Wed, 31 March 2021 20:54 Go to next message
kingswaygroup is currently offline  kingswaygroup
Messages: 52
Registered: June 2008
I have been assisting a customer who has been working with their Kerio Connect Client (started at 9.2.12 and currently 9.3.1 16367) to connect to their Kerio MailServer (Kerio Connect 9.2.12 patch 1 (5027)) for several months now. Their computer is a Windows 10 Home system with current patches. They also have Sophos Security and all the above have worked well since this machine was purchased in November.

The other day they went to use Kerio Connect Client and it came up with the splash screen and stayed there. The top menus (File Edit View...) were active but most items were greyed out. Doing the same with the Webclient gave the expected results and showed all the email.

I uninstalled the Client following the instructions here https:// support.kerioconnect.gfi.com/hc/en-us/articles/360015195719- Resetting-Kerio-Connect-Client-on-Windows including removing the files in the indicated folder, rebooted the system and reinstalled the client. No improvement.

I then removed the Sophos security software, rebooted, removed the Kerio Connect Client, rebooted, then reinstalled the Client. No improvement. The splash screen comes up but there is no request to give the location of the mail server and credentials and all the settings area in the menu is greyed out.

Can someone please direct me as to what other areas need to be cleaned up when the client is removed so that it will think that this is a fresh install? Or maybe it is thinking that this is a fresh install and something (a recent Windows update this week?) is interfering. I did not investigate it that far yet but then I would expect to see the same behaviour on other Windows 10 systems including my own.

Thank you for your assistance.

David


David Green
Re: Kerio Connect Client not connecting and not asking to do so [message #149565 is a reply to message #149564] Thu, 01 April 2021 04:40 Go to previous messageGo to next message
Nick.Geary is currently offline  Nick.Geary
Messages: 38
Registered: January 2021
I generally recommend opening a support ticket to look into any environmental factors. You could try using the KtUnInstaller Tool

https://support.kerioconnect.gfi.com/hc/en-us/articles/36001 5201459-Using-KTUninstaller


Nick Geary
GFI Software
Re: Kerio Connect Client not connecting and not asking to do so [message #149566 is a reply to message #149565] Thu, 01 April 2021 16:46 Go to previous messageGo to next message
kingswaygroup is currently offline  kingswaygroup
Messages: 52
Registered: June 2008
Nick:
Noticably the Uninstaller tool makes no mention of Kerio Connect Client. Seemingly that may stop me in my tracks. I tried all the options on my system and it had no affect on my Kerio Connect Client.
But let me ask this. How do I determine the Uninstaller code for Kerio Connect Client? Maybe I can run the KTUninstaller against that code.
Just to be clear, I do not want to uninstall my Kerio Outlook Connector, it is the Kerio Connect Client that I am trying to resolve for this customer.
Thank you for your assistance.
David


David Green
Re: Kerio Connect Client not connecting and not asking to do so [message #149682 is a reply to message #149566] Tue, 27 April 2021 23:07 Go to previous messageGo to next message
kingswaygroup is currently offline  kingswaygroup
Messages: 52
Registered: June 2008
Closing off this topic.
I found that setting up a new profile and installing Kerio Connect Client did not cause the problem to occur. With this in mind I worked with support to identify all the areas in the registry and on disk that may have remnants of the Connect Client to remove. This also included the Squirrel folders within AppData. Happily once I reinstalled Kerio Connect Client after the cleanup and reboot the program worked as would have been expected and asked for the credentials to get to the email account.

David


David Green
Re: Kerio Connect Client not connecting and not asking to do so [message #149753 is a reply to message #149682] Sun, 16 May 2021 15:00 Go to previous messageGo to next message
ketty shawn is currently offline  ketty shawn
Messages: 1
Registered: May 2021
I also seen this error splash screen and stayed there. The top menus (File Edit View...) windows were active but most items were greyed out. Doing the same with the Webclient gave the expected results and showed all the email. help me out.
Re: Kerio Connect Client not connecting and not asking to do so [message #149762 is a reply to message #149753] Wed, 19 May 2021 18:15 Go to previous messageGo to next message
kingswaygroup is currently offline  kingswaygroup
Messages: 52
Registered: June 2008
Let me try to assist.

Firstly, when you say you see the "error splash screen" I am uncertain as to whether you are seeing an error screen or the product banner screen. Under normal circumstances when starting the Kerio Connect Client where you have not previously provided credentials the first screen would offer you an opportunity to supply credentials, the display the top menu with the Kerio Connect banner screen and finally you would see the screen with your email similar to webmail. Where you already have credentials from a previous session Kerio Connect Client will jump directly to the email screen similar to webmail.

In my situation Kerio Connect Client would act as though credentials had been previously stored and not prompt for credentials but rather than jumping to the mail content screen it would go to the Kerio Connect banner screen with a mostly disabled menu (File, Edit, View...) structure at the top of the screen and sit there endlessly. I think this is what you are seeing but I am asking for confirmation. Note: To prove that Kerio Connect Client itself was working and it was a registry problem that was plaguing us we created a new profile, installed Kerio Connect Client, setup the profile and all worked as expected. In the original profile this did not happen.

If I am correct in my assumption then I will tell you to my best recollection what I did to remedy the situation, but first you must know that the user had closed down their system in such a way that may have caused some registry corruption.

The first thing I did was to uninstall Kerio Connect Client. Follow the instructions here remembering to remove the cache and reboot.
https://support.kerioconnect.gfi.com/hc/en-us/articles/36001 5195719-Resetting-Kerio-Connect-Client-on-Windows

After restarting you may wish to just try reinstalling Kerio Connect Client either by using the links on the Integration with Windows that is on your webmail credential page or by going directly to GFI here https://www.gfi.com/products-and-solutions/email-and-messagi ng-solutions/kerio-connect/resources/other-downloads/clients . I have at times had to use incognito mode to get the download from the webmail link and support confirmed that it is sometime necessary although they did not know why.

If you have reinstalled and it works, great, you won and you are done. Otherwise you need to go back to the beginning here, remove Kerio Connect Client, clear cache, and reboot.

One other note. I use CCleaner to clear up some leftover crud that Windows has gathered including registry keys and I recommend doing this before continuing. Home (free) version has what you need for this task.

So now you have to get into the registry. MAKE SURE YOU HAVE YOUR SYSTEM BACKED UP AND CAN DO A BARE METAL RESTORE just in case. Below is a list from GFI support of what they know of possible areas in the registry that are touched by the installation of Kerio Connect Client. The last line indicates that in their tests, all entries were removed by the uninstall process and for the most part I found this to be so, yet there were left over bits that I found elsewhere in searching for Kerio Connect through the registry - not a fun process - and not everything needs to be removed. I also found that references to "squirrel" might also be useful to remove as squirrelmail seems to be used by Kerio Connect Client.

In the end I cannot guarantee that your problem will be solved but this is what I did for my customer.

David.

Here are some locations that the Squirrel package uses. Before attacking the registry see if removing Squirrel from the file system is enough to remedy the problem.

C:\Users\<your user name>\AppData\Local\KerioConnect\packages
C:\Users\<your user name>\AppData\Local\KerioConnect
C:\Users\User_2\AppData\Local\Packages\Microsoft.Windows.Sea rch_cw5n1h2txyewy\LocalState\AppIconCache\150\com_squirrel_K erioConnect_KerioConnect




Content of support email to me on the topic of registry entries made by Kerio Connect Client:
I was able to test out all the registry entries that are installed within the Windows system after the installation of the Kerio Connect Client. I had some interesting findings:
There are multiple registries in the HKEY_CLASSES_ROOT​,HKEY_CURRENT_USER​andHKEY_USERS​reg isters in the registry editor. They all appear upon installation of Kerio Connect Client but they were all deleted effectively upon uninstallation of the software. There were no registry entries present in the registry editor after uninstalling Kerio Connect Client.
Now, the registries that are installed with the installation of Kerio Connect Client are as follows:
..\HKEY_CLASSES_ROOT\Applications KerioConnect.exe
..\HKEY_CLASSES_ROOT\KerioConnectClient.mailto
..\HKEY_CURRENT_USER\Software\Classes\Applications\KerioConn ect.exe
..\HKEY_CURRENT_USER\Software\Classes\KerioConnectClient.mai lto
..\HKEY_CURRENT_USER\Software\Clients\Mail\KerioConnectClien t
..\HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersi on\Uninstall\KerioConnect
..\HKEY_CURRENT_USER\Software\RegisteredApplications\KerioCo nnectClient
..\HKEY_USERS\S-1-5-21-2358436876-421447092-243695986-500\So ftware\Classes\Applications\KerioConnect.exe
..\HKEY_USERS\S-1-5-21-2358436876-421447092-243695986-500\So ftware\Classes\KerioConnectClient.mailto
..\HKEY_USERS\S-1-5-21-2358436876-421447092-243695986-500\So ftware\Clients\Mail\KerioConnectClient
..\HKEY_USERS\S-1-5-21-2358436876-421447092-243695986-500\So ftware\Microsoft\Windows\CurrentVersion\Uninstall\KerioConne ct
..\HKEY_USERS\S-1-5-21-2358436876-421447092-243695986-500\So ftware\RegistererApplications\KerioConnectClient
..\HKEY_USERS\S-1-5-21-2358436876-4214457092-2436959866-500_ Classes\Applications\KerioConnect.exe
..\HKEY_USERS\S-1-5-21-2358436876-4214457092-2436959866-500_ Classes\Applications\KerioConnectClient.mailto
Additionally, you can also open the Registry Editor and search it for the Kerio Connect Client registries after uninstalling it via common keywords such as KerioConnect​and KerioConnectClient​.
Please note, as I had tested, the registries were totally wiped after the uninstallation of the Kerio Connect Client. It's quite unlikely that they may still be around which might be causing the issue at hand.




David Green
Re: Kerio Connect Client not connecting and not asking to do so [message #150088 is a reply to message #149762] Thu, 29 July 2021 09:38 Go to previous messageGo to next message
JimmyKeen is currently offline  JimmyKeen
Messages: 2
Registered: July 2021
great, it works

check about the most reliable service https://www.essayontime.com/services/coursework.html for writing paper work
Re: Kerio Connect Client not connecting and not asking to do so [message #150096 is a reply to message #150088] Thu, 29 July 2021 21:14 Go to previous message
kingswaygroup is currently offline  kingswaygroup
Messages: 52
Registered: June 2008
Excellent!

So I was not the only one to experience this abnormality but I am very happy that I have been able to assist another person in this same situation.

David


David Green
Previous Topic: Outlook closes automatically and then opens again
Next Topic: send an email with an encrypted archive to spam
Goto Forum:
  


Current Time: Fri Dec 03 02:14:07 CET 2021

Total time taken to generate the page: 0.04570 seconds