GFI Software

Welcome to the GFI Software community forum! For support please open a ticket from https://support.gfi.com.

Home » GFI User Forums » Kerio Connect » Kerio Connect behind CloudFlare
Kerio Connect behind CloudFlare [message #144799] Tue, 15 January 2019 11:15 Go to next message
Panja0 is currently offline  Panja0
Messages: 10
Registered: January 2019

I'm running Kerio Connect and have port 25, 80 and 443 configured in KC.

At the moment I'm trying to setup CloudFlare.
I know CloudFlare does not support mail over their reverse proxy but I only want port 80 and 443.
So I have 2 DNS records created. record01.domain.com and record02.domain.com

record01 is used for delivering mail (port 25).
record02 is used for client to access over ActiveSync (443).

This works at the moment fine for all my ActiveSync clients (443): iPhone, Mac Mail and Outlook (Windows).

The problem is with the webmail interface.
I can access the page but after logging in I get a white screen and it does not go to the users mailbox.
Is there anything I can do to get this working?

This is the last piece of my CloudFlare reverse proxy puzzle.
Re: Kerio Connect behind CloudFlare [message #144827 is a reply to message #144799] Wed, 16 January 2019 13:19 Go to previous messageGo to next message
Panja0 is currently offline  Panja0
Messages: 10
Registered: January 2019
Got it fixed! I just made a Page Rule and put http s://mail.domain.com/* as a rule with Cache Level: bypass.

But now I have a next problem.
After around 100 seconds I get an error 524 - time out.

Checking the CloudFlare pages I found the issue described:
Error 524 error indicates that Cloudflare made a successful TCP connection to the origin web server, but the origin did not reply with an HTTP response before the connection timed out.

Typically, Cloudflare waits 100 seconds for an HTTP response. If the origin doesn't respond in that time, Cloudflare closes the connection and serves Error 524.


Someone have a clue how to fix this?

[Updated on: Wed, 16 January 2019 13:24]

Report message to a moderator

Re: Kerio Connect behind CloudFlare [message #144830 is a reply to message #144827] Wed, 16 January 2019 13:38 Go to previous messageGo to next message
Panja0 is currently offline  Panja0
Messages: 10
Registered: January 2019
Got that last problem fixed as well. Wink

Edited the mailserver.cfg file.
Under <table name="Webmail"> you'll find <variable name="LongPollTimeout">600</variable>.
I changed that one to 60 instead of 600.
Re: Kerio Connect behind CloudFlare [message #145705 is a reply to message #144830] Sun, 05 May 2019 08:30 Go to previous messageGo to next message
aidinbaran is currently offline  aidinbaran
Messages: 1
Registered: May 2019
Panja0 wrote on Wed, 16 January 2019 13:38
Got that last problem fixed as well. [img=images/smiley_icons/emoticon-0105-wink.gif]Wink[/img]

Edited the mailserver.cfg file.
Under <table name="Webmail"> you'll find <variable name="LongPollTimeout">600</variable>.
I changed that one to 60 instead of 600.

Thanks for sharing the information. that helped me alot.
I was recieving Error504 in webmail and all kerio management interfaces after setting them behind CDN. I changed the <variable name="LongPollTimeout">600</variable> to 60 and it is resolved.

Thanks again
Re: Kerio Connect behind CloudFlare [message #145716 is a reply to message #145705] Mon, 06 May 2019 13:18 Go to previous messageGo to next message
Maerad is currently offline  Maerad
Messages: 275
Registered: August 2013
Why do you put Cloudflare between you and Kerio? That makes not much sense IMHO. Anyone trying to "hack" kerio, would access it with the first DNS anyway, because they also do portlookups for that. Also a security layer would be the router / firewall with IDS, not a cloudservice.

And if someone would want to bring your Service down, they would DDoS the mailserver anyway.

Don't get me wrong, but I cant follow the reason, why you bring a 3rd party proxy into the equation, maybe worsening the problems, if the server itself is also accessible from connections WITHOUT cloudflare. In my brain, it makes no real sense at all. There is like no benefit. Or do I have some kind of thinking error?
Re: Kerio Connect behind CloudFlare [message #149939 is a reply to message #145705] Sat, 26 June 2021 18:15 Go to previous messageGo to next message
welltecnologia is currently offline  welltecnologia
Messages: 2
Registered: June 2021
Hi,

On my KC for Linux Version 9.2.1 (2397) it didn't work.
I changed the value to 60 and even so my Webmail keeps getting the Error 524 alert.

Please help me!
Re: Kerio Connect behind CloudFlare [message #149940 is a reply to message #145716] Sat, 26 June 2021 18:36 Go to previous messageGo to next message
welltecnologia is currently offline  welltecnologia
Messages: 2
Registered: June 2021
dont working...
Re: Kerio Connect behind CloudFlare [message #150014 is a reply to message #149940] Tue, 13 July 2021 15:38 Go to previous message
Mister-Magoo is currently offline  Mister-Magoo
Messages: 18
Registered: April 2005

It work also for me behind haproxy ...
Previous Topic: Kerio Connect Roadmap
Next Topic: KOFF: the sent mail can neither be found in the Outbox nor in the Sent Items folder
Goto Forum:
  


Current Time: Sun Dec 04 06:57:25 CET 2022

Total time taken to generate the page: 0.02844 seconds