GFI Software

Welcome to the GFI Software community forum! For support please open a ticket from https://support.gfi.com.

Home » GFI User Forums » Kerio Connect » v9.0.0 and NOD32 (A/V suddenly not working?)
icon4.gif  v9.0.0 and NOD32 [message #125927] Tue, 24 November 2015 02:54 Go to next message
El-Man is currently offline  El-Man
Messages: 11
Registered: October 2011
Location: New Zealand
Hello, all.

Client upgraded his Kerio connect to 9.0.0, and suddenly ESET NOD32 for Kerio doesn't want to work any more. NOD32 is asking to 'Register plugin to mail server' on its main page, and when turned on, it works for a minute, sometimes less, then goes right back to un-registered. Cannot find anything on the ESET forums relating to this, and neither here. Any ideas?
Re: v9.0.0 and NOD32 [message #126696 is a reply to message #125927] Sat, 26 December 2015 01:07 Go to previous messageGo to next message
El-Man is currently offline  El-Man
Messages: 11
Registered: October 2011
Location: New Zealand
*bump*

A month and nothing? Nobody can tell me anything?
Re: v9.0.0 and NOD32 [message #126697 is a reply to message #126696] Sat, 26 December 2015 11:26 Go to previous messageGo to next message
Pavel Dobry (Kerio) is currently offline  Pavel Dobry (Kerio)
Messages: 2057
Registered: October 2003
Location: Czech Republic
No wonder, you did not provide any detail nor log. We don't even know if you run 64-bit or 32-bit version or what version did you upgrade from.

[Updated on: Sat, 26 December 2015 11:26]

Report message to a moderator

Re: v9.0.0 and NOD32 [message #126698 is a reply to message #126697] Sat, 26 December 2015 12:09 Go to previous messageGo to next message
El-Man is currently offline  El-Man
Messages: 11
Registered: October 2011
Location: New Zealand
My bad. Was in a rush that day.

And I think I found something - in the NOD32 logs. "Failed to copy ESK plugin dll to kerio server installation directory". So the problem is not Kerio after all, I'll take it up with ESET. Sorry to bother you. Smile
Re: v9.0.0 and NOD32 [message #127439 is a reply to message #126698] Wed, 27 January 2016 14:35 Go to previous messageGo to next message
Muadib is currently offline  Muadib
Messages: 3
Registered: February 2015
Dear El-Man,

Im facing the same problem, and now im waitong reply from Eset. Can you share the solution pls? Thank you.
Re: v9.0.0 and NOD32 [message #127552 is a reply to message #127439] Mon, 01 February 2016 03:41 Go to previous messageGo to next message
El-Man is currently offline  El-Man
Messages: 11
Registered: October 2011
Location: New Zealand
When I hear back from Eset too, I'll report the answer.
Re: v9.0.0 and NOD32 [message #127553 is a reply to message #127552] Mon, 01 February 2016 08:04 Go to previous messageGo to next message
Muadib is currently offline  Muadib
Messages: 3
Registered: February 2015
Hi,


I received the following reply from ESET. It,s a workink solution.

"
As Kerio changed some paths in Kerio 9, the automatic plugin registration is not working currently.

The workaround is to register the plugin manually after the installation:

1. Turn Kerio Connect service off


2. Turn Kerio Connect registration off (ESET->F5->Server->Connect: off)


3. Copy following dll: c:\Program Files\ESET\ESET Security\x86\avir_esk.dll
to: c:\Program Files\Kerio\MailServer\plugins\avserver\Avirs\
to (crete directory manually): c:\Program Files\Kerio\MailServer\plugins\Avirs\
paths are necessary update based on kerio installation (default paths)


4. Edit Kerio Connect configuration file (c:\Program Files\Kerio\MailServer\mailserver.cfg)
Modify "Antivir" section as follow:
<table name="Antivir">
<variable name="AvirEnabled">1</variable>
<variable name="UsedInternal">0</variable>
<variable name="UsedPlugin">avir_esk</variable>
...
</table>
Modify "AntivirOptions" section as follow:
<list name="AntivirOptions">
</list>


5. Turn Kerio Control registration on (ESET->F5->Server->Connect: on)


6. Turn Kerio Control service on

"

Best Regards
Re: v9.0.0 and NOD32 [message #127752 is a reply to message #125927] Mon, 08 February 2016 13:07 Go to previous message
El-Man is currently offline  El-Man
Messages: 11
Registered: October 2011
Location: New Zealand
Thanks, Muadib. Was just able to try this out, and it works. Connect is once again protected! Laughing
Previous Topic: OSX Upgrade 10.6.8 to 10.9 Update and Kerio Update.
Next Topic: Kerio Connect Best Settings and Practices
Goto Forum:
  


Current Time: Thu Jun 01 09:52:25 CEST 2023

Total time taken to generate the page: 0.07232 seconds